Error: Cannot run with sound null safety, because the following dependencies don’t support null safety:

Error: Cannot run with sound null safety, because the following dependencies don’t support null safety: – package:flutter_appauth – package:flutter_appauth_platform_interface – package:plugin_platform_interface For solutions, see https://dart.dev/go/unsound-null-safety Unhandled exception: Bad state: Unsupported Null Safety mode NonNullableByDefaultCompiledMode.Invalid, in null. #0 ProgramCompiler.emitModule (package:dev_compiler/src/kernel/compiler.dart:471:9) #1 JavaScriptBundler.compile (package:frontend_server/src/javascript_bundle.dart:152:33) #2 FrontendCompiler.writeJavascriptBundle (package:frontend_server/frontend_server.dart:649:47) <asynchronous suspension> #3 FrontendCompiler.compile (package:frontend_server/frontend_server.dart:557:9) <asynchronous suspension>

Solution:- flutter run --no-sound-null-safety

Add Comment